Pleroma

I have some 30fps video and some 24fps video.

I need to sync the audio from the 30fps video to the 24fps video.

If I align the beginning, by the end I have Major (more than 1 second) slip over a 30 minute video.

This seems like it should be a solvable problem, but I'm not braining too well this week.

How might you approach this situation?

@ajroach42 another possibility that you might be able to use is to resync periodically in the middle of the video clip so that the audio plays at a regular speed, but the gaps between the audio can be extended as needed. I don't know if I'm making sense describing this. I can see it in my head I just don't know if I'm being clear.

@vertigo If I can't figure out a way to do this programatically, so I only have to do one sync, this is what I'll do.

It looks like I'm going to be getting *dozens* of videos that are like this, though, so getting an easy way to get it to all align automatically is really preferred.

@ajroach42 Oof, yeah, I see your point. Regrettably, I don't have any automated recommendations.

If I hear anything about this, I'll pass it along.

@ajroach42 Audio doesn't work in 24 or 30 fps, so extract the audio from one video and re-add it as an audio track to the other?
replies
0
announces
0
likes
0

@patrick right. That's what I did. But the sync is off by several seconds by the end of the video.

Did you split the audio from the video within kdenlive? If so, the time codes might have been messed up already when importing the video.
Another failure source could be 44kHz/48kHz differences.